Electricity on the datacenter has been restored and all the servers are back online!
Posted May 26, 2024 - 16:53 UTC
Identified
We regret to inform you that due to severe weather conditions in Texas, our datacenter is currently experiencing a complete power blackout. Initially, the power load was transferred to batteries and then to generators. However, after several hours, the generators were unable to sustain the power load, leading to a total outage.
We have been told that electrical engineers are on site now and are looking into it. Once we have more information regarding this matter we will update this page!
Posted May 26, 2024 - 13:23 UTC
This incident affected: Game Servers - US / CA (Dallas, TX).