Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 13, 2024 - 07:01 UTC
Scheduled
One of our infrastructure providers in New York will be performing an emergency router upgrade which may result in temporary downtime between 15 to 20 minutes.
The software upgrade includes a bug fix for a known routing issue, hence the importance and short notice about this.
If you have any questions or concerns regarding this, please reach out to us by submitting a support ticket!
Posted May 13, 2024 - 07:00 UTC
This scheduled maintenance affected: Game Servers - US / CA (New York, NY).